php5.4及其以上版本对自动转义的处理

不知php基于什么考虑的,从php5.4及以上版本已取消 magic_quotes_gpc  及magic_quotes_runtime 配置项,所以在php.ini中找不到这两个配置项了,get_magic_quotes_gpc()及get_magic_quotes_runtime()函数始终返回 FALSE,默认情况下PHP不会自动转义提交数据中的危险字符了,需自行处理这类数据。

php自动转义

发布者:天南

一个好人

留下评论

电子邮件地址不会被公开。 必填项已用*标注